Installation

Installation

Installation instructions

1. Download and install Microsoft .NET (if not already installed). Version 2.0 or later of .NET is required for MSQuant versions 1.4a17 and later.

2. Install software from at least one mass spectrometer vendor. Currently Sciex/Analyst and/or Finnigan/Xcalibur and/or Micromass/MassLynx is required/supported.

Notes for installation:

  • the QSTAR/Analyst software does not install or work on Microsoft Windows XP, Home Edition.
  • for Xcalibur remember to check "XDK" during installation.
  • Micromass: MassLynx version MUST be 4.0 (4.1 does not work at this time). If you want to create input files for the Mascot search: remember to check "ProteinLynx" (in the "Application Manager Options" wizard screen) during installation.

3. Download an MSQuant installer from our Web-server. (It is placed on our web-server because I can’t get the SourceForge file release system to work.)

4. Install MSQuant by running the installer (setup.exe). Note: you may get error messages for the mass spectrometer vendor software that you don’t have installed or need. E.g. if you only use Analyst/QSTAR you will get 2-3 error messages for files belonging to the Finnigan Xcalibur package. You can safely ignore those error messages. Specific example: if the Micromass software is not installted, the error message is "Module C:\Program Files\MSQuant\Mass spectrometry - MSQuant 2.0b7\DACServer.dll failed to register. HRESULT -2147024770. Contact your support personnel." (Dialog buttons: "Exit installation", "Try Again", "Continue"). Press button "Continue".

5. For QSTAR/Sciex/Analyst users only: if you have Analyst QS version 1.0 installed (in contrast to version 1.1) then you must do the following to use later versions of MSQuant:

  • Use an MSQuant installer from before August 2005. E.g.: MSQuantInstaller,2005-06-13,1.4a11.zip. Run the installer and do whatever is required if it does not work immediately, e.g. rename the folder of the current MSQuant installation, remove the current MSQuant installation in Settings/Control Panels/Add;Remove Programs/
  • Update the new MSQuant installation by copying the two files MSQuant.exe and SqlInterface.dll from a later version of MSQuant - from step 4.
  • Start the program. If needed, do the required thing for any file "MiscOptions.xml", "MSQ_quantitationModes.xml" and "new_spectrumClassification.xml".

Post installation (very important)

1. For Analyst: the so-called system path must contain the Analyst bin folder. Otherwise you will get an error message about some DLL that can not be found (FMWIFFCompDocNTDriver.dll). What to do:

  • Right-click "My Computer" to get the "System Properties" dialog.
  • go to the "Advanced" tab and click "Environment Variables"
  • for "System variables" click on the "Path" entry then click "Edit"
  • add ";C:\Program Files\Analyst\bin" (or wherever you’ve installed Analyst to the end of the string). It is important to append to the end of the string: Don’t replace the string! Do not include the two quotes.
  • (You can check the success by opening a command line window: Start menu/run, type "cmd", [enter], a command line window opens into which you type "set", [enter]). Look for "Path=". Verify that it contains "C:\Program Files\Analyst\bin". Another check is to type "Analyst" (without the quotes) in the command line window. This should start the Analyst program, otherwise you will get this message:
    "Analyst" is not recognized as an internal or external command, operable program or batch file.
  • Restart the computer. This has been observed to be necessary in at least one instance.

2. For Finnigan/Xcalibur: during installation of Xcalibur "XDK" must have been checked (it is off by default). If you have already installed it without the XDK then you should take steps to remedy this situation; e.g. reinstalling with XDK checked should work. Disclaimer: do it at your own risk. Before you reinstall save any changes you have made to your existing installation, e.g. extra modules that were added after initial installation.

Other considerations

MSQuant is very memory hungry, depending on the size of the search result and possible use of retention time cross-correlation. We recommend as much RAM in the computer as possible. We strongly recommend setting the virtual memory to the maximum of 2 GB. This can be done as follows: Right-click on "My Computer" on the desktop. Properties. tab Advanced. Performance Options. Change. Set "Initial size (MB)" to 1700. Set "Maximum size (MB)" to the same number, 1700. OK. OK. OK. It may be necessary to restart the computer.

Troubleshooting MSQuant installation

  1. Did you check the option "XDK" when you installed Xcalibur?? (For LTQ-FT;LTQ-Orbitrap/Finnigan/Xcalibur). At least these 3 files must be in the "system\programs" folder in the Xcalibur installation: XRawfile2.dll, XcaliburFiles.dll and XcaliburDisplays.dll. This folder contains "QualBrowser.exe".
  2. The installation fails on Windows XP.
    • Some regular XP user accounts do not have enough rights to install MSQuant. At this time it is not known what rights are required, but the Adminstrator account has enough rights.
    • Even with the above, installation fails with this message: "This advertised application would not be installed because it might be Unsafe. Contact your administrator to change the installation user interface option of the package to basic.".
      Dr. Waltraud Schulze (Max-Planck Institut für Molekulare Pflanzenphysiologie, Potsdam, Germany) found a solution:
      "open a command line window: Start menu/run, type 'cmd', [enter], a command line window opens into which you type:

      msiexec /qb /I c:\thefolderinwhichisyourinstaller\MSQuantSetup.msi

      It seems to be a common problem with some .NET Group Policy programs. I found the precise hint on a website about troubleshooting similar problems in MATLAB."

Getting started

1. Download one of the example raw file sets:

  • QSTAR. Name: QSTAR sample data set number 1. Dataset for triple encoding (Arg6/Arg10 labelling). Mascot search result (Mascot 2.1): "Peptide Summary Report (Triple Encoding SILAC sample data).htm". QSTAR spectrum file: "Triple Encoding SILAC sample data.wiff". Download size: 44 MB. Set quantitation mode to "Arg13C6 and Arg13C615N4".

  • LTQ-FT;LTQ-Orbitrap. Name: LTQ-FT;LTQ-Orbitrap sample data set number 1. Relative small dataset that will parse fast. Mascot search result (Mascot 2.1): "LTQ-FTsampleDataSet1.htm". Finnigan spectrum file: "LTQ-FTsampleDataSet1.raw". Download size: 51 MB. Set quantitation mode to "No Isotope".

  • LTQ-FT;LTQ-Orbitrap. Name: LTQ-FT;LTQ-Orbitrap sample data set number 2. Famous Lyris-Yeast data set. Demonstrates how extremely high quality spectra can be acquired if you do not put mass spectrometer poison, DHB (2,5-dihydroxybenzoic acid) , into the mass spectrometer. Or somebody else does it without your knowledge. High intensity fragments are fragmented (MS3) for increased confidence in peptide identification. Mascot search result (Mascot 2.2): "Lyris_YeastSILAC_Lys8-MS3_5ppm_Mascot22.htm". Finnigan spectrum file: "Lyris-YeastSILAC_Lys8-MS3.RAW". Download size: 679 MB. Set quantitation mode to "v2.2 Lys13C615N2" (this mode is not defined by default - but is in CEBI's version of the MSQuant settings file "new_MSQ_quantitationModes.xml", 2008-08-28 or later.). If you are not interested in quantitation for this dataset then set quantitation mode to "No Isotope".

  • Qtof. Name: Qtof sample data set number 2. Dataset for N15 labeling. Mascot search result (Mascot 2.1): "Yeast_N15_Short.html". Micromass spectrum file folder: "Yeast_N15_Short.raw". Download size: 11.5 MB. Set quantitation mode to "N15 labeling".

2. Open the program.

3. Set appropriate raw data file type (menu Tools/Options, Raw file type, QSTAR/LTQ-FT;LTQ-Orbitrap/Qtof.)

4. Set appropriate quantitation mode, matching the data (menu Tools/Options, Quantitation mode, Arg13C6/Lys13C6/Arg13C6 and Arg13C615N4/HysTag/No isotope/N15 labeling)

5. Prepare for parsing the Mascot result file:

  • Choose a Mascot HTML result file (right-click in left pane/Add single Mascot file).
  • Choose a raw file (right-click in right pane/Add single raw data file).
  • Select the Mascot result file and the raw file.
  • Associate (right-click in left pane/Associate with highlighted raw data file).
  • Save (menu File/Save File associations. OK.).

6. Double-click on the Mascot HTML result file in the left pane. This will start parsing the protein and peptide information from the Mascot HTML result file. Eventually the Protein List window will be filled with the proteins from the Mascot search result file.

7. Double-click on the top protein. This will open the Protein Validation window.

8. Double-click on a peptide. The MS-MS spectrum will be displayed. For this to work and all other operations that requires access to the raw spectrum see the section below, "Preparing input files for the Mascot search engine".

9. Quantitate:

  • In the Protein Validation window: menu Quantitation/Open Quantitation window. This will open the Quantitation window.
  • Select one or more peptides in the peptide list. Choose menu Quantitation/Quantitate. This will quantitate the selected peptides. You can also double-click on a single peptide to quantify it.
  • You can export the result of the quantitation by selecting one or more peptides and then invoke menu command File/Protein, Peptides and Spectra Information (&export)...". This should open an Open Office Calc or Excel window with the information.

If all this works then you are ready to try it on your own data. The input file for the Mascot search must be formatted in the way that MSQuant expect. See next section, "Preparing input files for the Mascot search engine".

Preparing input files for the Mascot search engine

MSQuant uses the retention time (for the MS-MS event) for a peptide in order to find the MS-MS and corresponding MS spectrum in the raw spectrum file.

This information is expected by MSQuant to be in a particular format. It should be placed in the TITLE fields in the Mascot input file (in Mascot Generic Format, file extension .mgf, .msm, .tmp or .txt). Within the TITLE field it should be in the sub-field "Elution from:" Sample (for QSTAR):

      TITLE=Elution from: 31.16 to 31.16   period: 0   experiment: 4 cycles:  1
    

Elution = retention time. Unit is minutes.

QSTAR

Version 1.1 of Analyst: Mascot.dll now creates a bastard output format. In order to use MSQuant a script, QSbroken2QSclassic, must be run to convert the output of Mascot.dll to an appropriate format. The script expects a file in the Mascot Generic Format (MS/MS Ions Search) as input, but does not require a particular file extension. The nominal file extension is .MGF, but different tools uses different file extensions. We know of 3 other file extensions: .TMP, .MSM and .TXT. .TMP is used by the some versions of the Mascot.dll script (QSTAR/Sciex/Analyst). The output file is also in Mascot Generic Format. The file name, including file extension, is specified by the user, in the BAT file; QSbroken2QSclassic.bat. Thus you must first edit this BAT file to fit your particular location and file names. Then double click on it to start the conversion. Perl must be installed on your computer in order for this to work. For Windows computers we can recommend ActivePerl, http://www.activestate.com/activeperl/?psbx=1. The exact version number does not matter.

Version 1.0 of Analyst: the built-in tool, Mascot.dll, or the proprietary tool "IDA processor" should create the correct format.

LTQ-FT;LTQ-Orbitrap

For Finnigan DTA files the retention time information is not provided. Instead the spectrum number is encoded in the file name. Example: "overnight.1169.1169.3.dta". This spectrum number must be put into the field "FinneganScanNumber", otherwise the retention time is read from the field "Elution from". Sample:

        TITLE=Elution from: 777.777 to 777.777 period: 0 experiment: 1 cycles: 1 FinneganScanNumber: 1169
      

If the field "FinneganScanNumber" exists then MSQuant ignores fields "Elution from"/"to" - FinneganScanNumber overrides those fields.

DTASuperCharge

A .NET application, DTASuperCharge, is available to convert one or more Finnigan .RAW files to Mascot search input files in a format suitable for use with MSQuant. DTASuperCharge is bundled with later versions of MSQuant and this is currently the only way of getting recent versions of DTASuperCharge.
Installation:

  • Install MSQuant first, including parsing and opening of Protein Validation windows for the sample data set. This requirement will be removed in a future version, but in any case it is a good way to test whether the installation of Xcalibur is working.
  • run the installer (for older versions only). If you want to have DTASuperCharge run "extract_msn.exe" for you to generate the DTA files, then make sure "extract_msn.exe" is installed in the Xcalibur installation and that the modification date of "extract_msn.exe" is 2004-06-04 or later. As far as I know: "extract_msn.exe" is part of BioWorks and thus you must have a license for BioWorks to install and use "extract_msn.exe".

Getting started with DTASuperCharge

  • Start the program.
  • Tab "Preprocess": set the full path to "extract_msn.exe" in the first input field (assuming you want the program to run "extract_msn.exe" for you - otherwise unclick the checkbox).
  • Set parameters as appropriate on the tab "DTA processing". Tab "File Parameters" let you filter out/split/merge the different fragment spectra types (e.g. MS2 and MS3) - the default is to split the different fragment spectra types into separate Mascot input files (.MGF) files.
  • Start the conversion by starting the menu command Convert/Start Conversion.
  • If all goes well a number of MGF files will be generated. Progress of the process can be followed on the tabs "Output2" and "Manual".
  • If needed you can now use the manual features in the Convert menu and the tab Manual to change e.g. C12 peak and charge assignments. This activity will change the content of the DTA files in the output DTA folder. In order to get these changes into a Mascot input file (.MGF) you have to command the program to do the postprocessing again (menu Postprocess/All postprocessing).

Qtof

To create the input file for Mascot, some options need to be set correctly. In the ProteinLynx module (NOT ProteinLynx Global Server) in Masslynx, the option "Append data to single file" should be unchecked. In this case the MS/MS channel number, the scan number and the charge are encoded in all files. Example: "overnight.117.3.2.pkl". Copy the Perl script and the driver BAT file (see below) to the output directory, edit the BAT file as appropriate and execute it.

A Perl script, PKL2Mascot.pl, is available to prepare .PKL (peak list) files for search for Mascot such that MSQuant will be able to find the MS-MS and MS spectra. Location: PKL2Mascot,2004-02-21.zip.

The output of the script is the input to the Mascot search. Perl must be installed on your computer in order for this to work. For Windows computers we can recommend ActivePerl, http://www.activestate.com/activeperl/?psbx=1. The exact version number does not matter.

Part of the output of this script will look similar to:

          BEGIN IONS
          PEPMASS=446.7263
          CHARGE=2+
          TITLE=Elution from: 9999.99 to 9999.99 period: 0 experiment: 3 cycles: 1 FinneganScanNumber: 117
          183.1330 11.0000
          228.1346 13.0000
          261.1865 14.0000
          552.2947 11.0000
          665.4302 8.0000
          762.4420 13.0000
          END IONS
        

Regarding .IDX files: the .RAW folder contains several .IDX files. MSQuant needs to know what the location of the .RAW directory is and this is done by selecting an .IDX file (does't matter which one).

Combining several raw spectrum files

MSQuant can handle multiple raw data files at a time, e.g. for protein correlation profiling (PCP). This is described in further detail in a separate document. It relies on a Perl script to put the necessary raw file name information into the Mascot search input file. All the files (scripts and documents) for this can be downloaded as a single ZIP package.

Note 1: this currently only works for QSTAR and LTQ-FT;LTQ-Orbitrap data, not Qtof (a future version of MSQuant may change this). Note 2: the script in this package has not been updated to understand Mascot.dll for QS 1.1 (or later) output. You can work around this by using the QSbroken2QSclassic script.

Tips

  • Quantitation (crucial for LTQ-only data): zoom in on an isotope cluster used for quantitation (lower left in the Quantitation Window). The mass range indicated by the two blue lines ("qwl" and "qwr") is used for quantitation. If it is too narrow or too wide for your data then adjust the width by editing the settings file "new_MiscOptions.xml". The massWindowForXICxxx field is the primary value. If the mass width is mass dependent the field "massForMassWindow" specifies at which mass the massWindowForXICxxx value is valid. It is mass dependent if field "massWindowFunctionxxx" is "enumSquareMass" (mass width is proportional to the square of the mass - e.g. for FT data). Do test it with the new values for both high and low MCR (mass-charge-ratio) values. Note: the program must be restarted in order for new values in file "new_MiscOptions.xml" to take effect.
  • How to convert the MSQuant peptide/spectrum report to PDF (e.g. for your MCP paper...): a. Download and install the application "XMLmind FO Converter". (Go to original download place.) b. Start the application (menu start/Programs/XMLmind FO Converter/XSL Utility). c. Select the "XML Input File": the one generated by MSQuant. d. "Transformation": set it to "DocBook to PDF". e. Press "Convert". There will be a lot of warnings and error messages, but if "FO processed in x.xx s." appears then it is fine.
  • If you use PTM scoring then the prefix and the postfix strings for modifications must not contain uppercase letters. This is a restriction, not a bug. This restriction may be lifted in a future version. Sample; this will not work: <shortPrefix>N-acp</shortPrefix>

Installation/usage notes

  • Note 1: if you use Finnigan data (and for older versions of MSQuant: Qtof data) then the "XDK" option *** must *** have been selected during installation of Xcalibur (this includes when you upgrade, e.g. from Xcalibur 2.0 SR1 to Xcalibur 2.0 SR2). This applies for all versions of MSQuant, not just this version.
  • Note 2: See note 1.
  • Note 3: now it is in fact possible to use the previous version of Analyst QS, v. 1.1, without having to resort to some trick with installing older versions of MSQuant and copying some files. Open menu Tools/Options. Press OK (this will update settings file MascotParserOptions.xml with a new field, COMversion). Change the value of field COMversion to "enumAnalystQS11".
  • Note 4: MSQuant can only parse Mascot result files (.html) saved with Internet Exploiter 6 or earlier. It does not immediately work with these browsers: Internet Exploiter 7, Opera, FireFox, Netscape and others. There is however a work-around: a utility (.NET application) is available to convert a Mascot result file to the form of HTML that MSQuant expects. Use the button "Convert to MSQuant Readable File..." -ignore the other buttons in this application!!!!!!!. In the future MSQuant will be made browser agnostic.
  • Note 5: if you use LTQ-FT;LTQ-Orbitrap (or other Finnnigan instrument) data then this version of MSQuant requires Xcalibur 2.0 SR1 or later (SUR1 or SUR2 or SUR3, on their own, will not work. They don't hurt either, but SR1 must be installed and be installed first). This restriction will be lifted in a future version of MSQuant.
  • Note 7: Microsoft .NET 2.0 is required, .NET 1.1 will not work.
  • Note 8: if you use Qtof then this version of MSQuant requires MassLynx 4.0. The newer MassLynx 4.1 will not work; this may change in the future.

MSQuant bundled helper applications

MSQuant helper applications
Supporting pre- and post-processing
Name Version Date Purpose Notes
PILGrinder 1.03 2009-02-12 Simple mass calculations for peptides.
DTASuperCharge 1.33 2009-01-30 Create Mascot input file from Finnigan LTQ-FT;LTQ-Orbitrap raw files.
Mascot Result Launcher 1.04 2008-11-11 Efficient retrieval of the Mascot result file. Also contains a utility for converting non-Internet Exploiter 6 files to the format expected by MSQuant. The on-demand formatting feature does not work if Mascot user access features are used on the Mascot server.
Mascot Result Viewer N/A 2007-12-17 Extract a few specified proteins from the Mascot result file (to avoid waaaaaaiiiiiiting for the browser to show the whole file). The tooltips do not work. Perl, e.g. ActivePerl, is required to be installed.
Finnigan Number Stripper N/A 2008-02-01 Remove spectrum number fields from the Mascot result file. Allows use of MSQuant as a parse-only tool - the raw file is not accessed (and thus does not require any mass spectrometer software is be installed or can be used with mass spectrometers not supported by MSQuant). Only works for the MSQuant formats - not for Mascot Distiller or Proteome Discoverer. Perl, e.g. ActivePerl, is required to be installed.
Mascot Result File Reductor N/A 2008-08-19 Make the Mascot result file 5 times smaller... Can be crucial for parsing it at all. Does not work for Mascot 2.1 result files, e.g. some of the sample files referenced in the Getting started section on this page. Perl, e.g. ActivePerl, is required to be installed.
MGFcombiner 1.10 2008-09-26 Merges MGF files and makes the MGF file suitable for MSQuant. The underlying script is MultRawPrepare; referenced elsewhere on this page. Put MGF files in sub folder(s) under the specified input folder. This will name the output MGF file(s) after the sub folder name(s). The specified output file does not have any effect (an empty file is created...) and an extra MGF file, ".mgf" is generated. Perl, e.g. ActivePerl, is required to be installed.
MSRecal 1.10 2008-07-31 Recalibrates precursor masses, split into ID and non-ID peaklists. Greatly reduces input size for a second Mascot search - important for combined files. Perl, e.g. ActivePerl, is required to be installed.